【***系列六】cisco“双center单云”和“双center双云”冗余规划Dm***实例比照浅析51CTO博客 - 凯发娱乐

【***系列六】cisco“双center单云”和“双center双云”冗余规划Dm***实例比照浅析51CTO博客

2019年02月28日12时14分36秒 | 作者: 浩歌 | 标签: 装备,实例,比照 | 浏览: 2369

 

【***系列六】cisco“双center单云”和“双center双云”冗余规划Dm***实例比照浅析

条件

ROUTER IOS 版别

 

鉴于前次版别不共同,形成show crypto 成果有差异,这次悉数选用同一个版别,保证成果精确共同。

 

一、“双center单云”Dm*** 实例

 

 

 

 

 

 

 

 

装备流程

1.装备network

a、保证网络环境互通

ip route 0.0.0.0 0.0.0.0 200.0.10.1

ip route 0.0.0.0 0.0.0.0 200.0.20.1

ip route 0.0.0.0 0.0.0.0 200.0.30.1

ip route 0.0.0.0 0.0.0.0 200.0.40.1

b、路由互通之后,装备tunnel口才干up,不然即便之后装备的动态路由协议也是不能uptunnel口的,这点很重要。            

  

2.装备 interface tunnel and mgre

这儿装备GRE的形式为multipoint,这样就能够多点衔接

 

3.装备 crypto isakmp policy

惯例装备,我们都该了解了

4.装备 crypto isakmp key

由于是多站点衔接,所以是选用0.0.0.0 0.0.0.0 ,表明恣意地址

5.装备 crypto ipsec transform-set

这儿是转化集的装备,要点在于挑选ipsec 加密形式为传输形式,由于现已选用gre技能,创立地道了。

6.装备 crypto ipsec profile

相关转化集,也是要点环节

7.装备 tunnel protection ipsec profile

在tunnel口有必要启用的指令,类似于crypto map ,就是启用***的要害指令

8.装备 ip nhrp

hub的ip nhrp 装备信息(要点部分)

注:两个hub之间 彼此指定映射

ip ospf network //指定tunnel口ospf 网络类型为broadcast

ip ospf priority xxxx //指定tunnel的ospf 优先级,这样保证两个hub成为DR 和BDR,其他spoken为DROTHER不参加推举,保证网络路由环境正常。

 

spoken的ip nhrp 装备信息(要点部分)

  spoken要一起映射两个hub

ip nhrp map multicast  x.x.x.x  //映射hub的外网口地址

ip nhrp map x.x.x.x  x.x.x.x     // 映射hub的tunnel口地址与外网口地址之间的联系

ip nhrp nhs x.x.x.x    //映射hub的tunnel口地址

9.装备 dynamic router protocol

10.show result

  注:

1.在装备动态路由时肯定不能将外网口的ip地址也发布进去,否者会形成路由翻滚,很严重的反响,路由肯定是不会通了,并且系统资源占用率很高。

2.创立一个standard acl 过滤0.0.0.0 入站,避免环路

ip access-list sta filter-hub

deny 0.0.0.0

permit any

router ospf 100

distribute-list filter-hub in tunnel 0

 

 二、“双center双云”Dm*** 实例

 

 

 

 装备流程

1.装备 network

(略)

2.装备 crypto isakmp policy

3.装备 crypto keyring

  (略)

 4.装备 crypto isakmp profile

(略)

5.装备 crypto ipsec transform-set

 6.装备 crypto ipsec profile

7.装备 interface tunnel and mgre、ip nhrp  

  center1的tunnel口装备:

 ip nhrp network-id 装备不同的序号,以此区别不同的tunnel衔接

   

  center2 的tunnel口装备:

 spoken1 的tunnel1口装备:

 spoken1 的tunnel2口装备:

 

8.show result

  

 

  

 

 

  

 

 

 . 

 

 

 

  

 

  

 三、小结

 
DM*** 拓扑结构 Center 比照 Spoken 比照
双center单云 相同之处: 1.两种拓扑结构中center上的tunnel口都只需创立一个,都是运用GRE Multipoint形式. 2. 两种拓扑结构中center上的tunnel口都运用nhrp协议,来注册spoken信息. 3. 两种拓扑结构中center都能够运用动态路由协议。 4.都能够运用优化指令来优化spoken之间的最佳路由,使得spoken与spoken之间能够直接通讯,而不需求把流量悉数转发给center,减轻center负载。   不同之处: 1.“双center单云”中的center的tunnel口需求彼此映射,“双center双云”中的center不需求. 2.“双center单云”中的center的tunnel口上创立的nhrp network-id和tunnel key 都是相同的,“双center双云”中的center的tunnel口的nhrp network-id和tunnel key都是不同的. 相同之处: 1.两种拓扑结构中spoken都运用nhrp协议来向center注册信息. 2.两种拓扑结构中spoken都需求创立tunnel口. 3. 两种拓扑结构中spoken都能够运用动态路由协议。   不同之处: 1.“双center单云”中的spoken只需创立一个tunnel口,可是一个tunnel口需求一起映射两个center的tunnel口,“双center双云”中的spoken需求创立两个tunnel口,每个tunnel口只需映射对应的一个center的tunnel口。 2.“双center单云”中的spoken创立的tunnel口运用GRE Multipoint形式,“双center双云”中的spoken创立的tunnel口运用静态拟定形式.  
双center双云

 

 以上都是个人在工作和试验中得出的一些见地,有不足之处还请我们纠正。

     

 

 

 

 

 

 

 

 

 

 

版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表凯发娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章